I ran into the same question when writing our jest bindings - is it Jest.Fn.make()
, Jest.fn()
or jest.fn()
?
My vote would go for Navigator.cookieEnabled
. It has the same ergonomics but is namespaced nicer. As much as I like the direct navigator.cookieEnabled
, when you need to add function bindings the former makes it more clear where you can look for those functions (i.e. Location.assign
)